armsr: armv8: enable serial console for Renesas platforms
[openwrt/staging/stintel.git] / include / prereq-build.mk
index 9096e379bb0f7aa76e7fb5783e39015af40387f5..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
@@ -32,28 +32,30 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 6 or later, \
-       $(CC) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
-       gcc -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       Please install the GNU C Compiler (gcc) 8 or later, \
+       $(CC) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       Please reinstall the GNU C Compiler (6 or later) - \
+       Please reinstall the GNU C Compiler (8 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c -o $(TMP_DIR)/a.out -))
+               $(STAGING_DIR_HOST)/bin/gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 6 or later, \
-       $(CXX) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
-       g++ -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       Please install the GNU C++ Compiler (g++) 8 or later, \
+       $(CXX) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++ -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       Please reinstall the GNU C++ Compiler (6 or later) - \
+       Please reinstall the GNU C++ Compiler (8 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(STAGING_DIR_HOST)/bin/g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
 $(eval $(call RequireCHeader,ncurses.h, \
@@ -94,6 +96,10 @@ $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))
 
+$(eval $(call TestHostCommand,perl-ipc-cmd, \
+       Please install the Perl IPC:Cmd module, \
+       perl -MIPC::Cmd -e 1))
+
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \
        gnutar --version 2>&1 | grep GNU, \
@@ -232,4 +238,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))