scan.mk: do not silence output of dump phase
[openwrt/staging/stintel.git] / include / prereq-build.mk
index 5b63490ca3c6754a4c2ac276310ec45331fff511..2378f5ad90c961472f8751f2d116f9978d976b7d 100644 (file)
@@ -32,28 +32,30 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 6 or later, \
-       $(CC) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
-       gcc -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       Please install the GNU C Compiler (gcc) 8 or later, \
+       $(CC) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       gcc-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       Please reinstall the GNU C Compiler (6 or later) - \
+       Please reinstall the GNU C Compiler (8 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c -o $(TMP_DIR)/a.out -))
+               $(STAGING_DIR_HOST)/bin/gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 6 or later, \
-       $(CXX) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
-       g++ -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
+       Please install the GNU C++ Compiler (g++) 8 or later, \
+       $(CXX) -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++ -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
+       g++-8 -dumpversion | grep -E '^([8-9]\.?|1[0-9]\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       Please reinstall the GNU C++ Compiler (6 or later) - \
+       Please reinstall the GNU C++ Compiler (8 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(STAGING_DIR_HOST)/bin/g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
 $(eval $(call RequireCHeader,ncurses.h, \
@@ -180,6 +182,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -188,6 +191,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
        python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -236,4 +240,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(SCRIPT_DIR)/noop.sh $(STAGING_DIR_HOST)/bin/ldconfig))