kernel: bump 5.15 to 5.15.131
[openwrt/staging/stintel.git] / include / depends.mk
index 465e4e952a9a546c5729a20d3eb8746179941e2f..a858d4b033eb47e7b83564d578f78596914b79ce 100644 (file)
@@ -12,6 +12,7 @@
 DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp" -x "*/.pkgdir*"
 
 find_md5=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) -printf "%p%T@\n" | sort | $(MKHASH) md5
+find_md5_reproducible=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) -print0 | xargs -0 $(MKHASH) md5 | sort | $(MKHASH) md5
 
 define rdep
   .PRECIOUS: $(2)
@@ -27,7 +28,7 @@ ifneq ($(wildcard $(2)),)
                { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
        ) \
        { \
-               [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+               [ -f "$(2)_check.1" ] && mv "$(2)_check.1" "$(2)_check"; \
            $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
                        $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
                        touch -r "$(2)" "$(2)_check"; \