build: fix kernel 5.4 on macos
[openwrt/staging/rmilecki.git] / tools / Makefile
index 3c37316b96f252abd5f934fd7a08a34c666c7bff..02556d4b83f3e44bef980ba0d8748933645a79a1 100644 (file)
@@ -138,6 +138,10 @@ $(STAGING_DIR_HOST)/.prepared: $(TMP_DIR)/.build
        mkdir -p $(BUILD_DIR_HOST)/stamp $(STAGING_DIR_HOST)/include/sys
        $(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
        $(INSTALL_DATA) $(TOPDIR)/tools/include/sys/*.h $(STAGING_DIR_HOST)/include/sys/
+ifneq ($(HOST_OS),Linux)
+       mkdir -p $(STAGING_DIR_HOST)/include/asm
+       $(INSTALL_DATA) $(TOPDIR)/tools/include/asm/*.h $(STAGING_DIR_HOST)/include/asm/
+endif
        ln -snf lib $(STAGING_DIR_HOST)/lib64
        touch $@