build: drop UBI EOF marker from images by default
[openwrt/staging/rmilecki.git] / target / linux / mvebu / image / Makefile
index 7d87e5cc8fd39c5904b953ca8628b924da3614ca..c855cca42cc4f917ff35f762e64c2804c0153091 100644 (file)
@@ -14,25 +14,47 @@ KERNEL_LOADADDR := 0x00008000
 
 DEVICE_VARS += KERNEL_SIZE
 
-define Image/mkfs/bundle
-       $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               -C $(call mkfs_target_dir,$(1))/ . > $@
-endef
-TARGET_FILESYSTEMS += bundle
-
 define Build/dtb
         $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
 endef
 
 define Build/clearfog-bundle
-       cp $(IMAGE_ROOTFS) $@.new
+       rm -f $@.new
+       $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
+               --file=$@.new -C $(TARGET_DIR)/ .
        $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               --file=$@.new -C $(dir $(IMAGE_KERNEL))/ $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
+               --file=$@.new -C $(dir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
        gzip -9n -c $@.new > $@
 endef
 
+# SD-Card Images:
+# these values are optimized for a 4GB labeled sdcard that actually holds 7744512 sectors of 512 byte
+# MBR:            2048 sectors
+# Partition 1:   32768 sectors
+# Partition 2:   98304 sectors (configurable)
+
+define Build/boot-scr
+       rm -f $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.script $@.bootscript
+endef
+
+define Build/boot-img
+       rm -f $@.boot
+       mkfs.fat -C $@.boot 16384
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
+       mcopy -i $@.boot $@.bootscript ::boot.scr
+endef
+
+define Build/sdcard-img
+       ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
+       ./gen_mvebu_sdcard_img.sh $@ \
+               "$(BIN_DIR)/uboot-mvebu-clearfog/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               c 32768 $@.boot \
+               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+endef
 
 define Device/Default
   PROFILES := Default
@@ -40,7 +62,6 @@ define Device/Default
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
-  FILESYSTEMS = $(filter-out bundle,$(TARGET_FILESYSTEMS))
 endef
 
 define Device/UBI
@@ -50,13 +71,14 @@ endef
 
 define Device/UBI-factory
   $(Device/UBI)
+  UBINIZE_OPTS := -E 5
   IMAGES += factory.img
   IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
 endef
 
 define Device/NAND-128K
   $(Device/UBI)
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   PAGESIZE := 2048
   SUBPAGESIZE := 512
   VID_HDR_OFFSET := 2048
@@ -64,13 +86,13 @@ endef
 
 define Device/NAND-256K
   $(Device/UBI)
-  BLOCKSIZE := 256KiB
+  BLOCKSIZE := 256k
   PAGESIZE := 4096
 endef
 
 define Device/NAND-512K
   $(Device/UBI)
-  BLOCKSIZE := 512KiB
+  BLOCKSIZE := 512k
   PAGESIZE := 4096
 endef
 
@@ -118,9 +140,9 @@ TARGET_DEVICES += linksys-wrt1900ac
 define Device/openblocks-ax3
   $(Device/UBI-factory)
   DEVICE_DTS := armada-xp-openblocks-ax3-4
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   PAGESIZE := 1
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+  IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3
@@ -155,9 +177,10 @@ define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
   KERNEL := dtb | kernel-bin
   DEVICE_TITLE := SolidRun ClearFog
-  FILESYSTEMS := bundle
-  IMAGES := bundle.tar.gz
-  IMAGE/bundle.tar.gz := append-rootfs | clearfog-bundle
+  DEVICE_PACKAGES := uboot-mvebu-clearfog mkf2fs e2fsprogs
+  IMAGES := bundle.tar.gz sdcard.img.gz
+  IMAGE/bundle.tar.gz := clearfog-bundle
+  IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
 endef
 TARGET_DEVICES += armada-388-clearfog