brcmfmac43430-firmware: rename to brcmfmac-firmware-43430-sdio
[openwrt/staging/rmilecki.git] / target / linux / brcm2708 / image / Makefile
index 35a72958daa30dee484e361b89cc56580381f38b..f19f57cb2ce1add051f6595b4f20c23256e3231a 100644 (file)
@@ -30,7 +30,7 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
-       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::kernel.img
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
        mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
@@ -38,7 +38,7 @@ define Build/boot-img
 endef
 
 define Build/sdcard-img
-       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
        $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
@@ -49,30 +49,31 @@ define Device/Default
   KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
   IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/rpi
-  SUBTARGETS := bcm2708
-  DEVICE_TITLE := Raspberry Pi B/B+/CM
+  DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
 endef
-TARGET_DEVICES += rpi
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi
+endif
 
 define Device/rpi-2
-  SUBTARGETS := bcm2709
   DEVICE_TITLE := Raspberry Pi 2 B
   DEVICE_DTS := bcm2709-rpi-2-b
 endef
-TARGET_DEVICES += rpi-2
+ifeq ($(SUBTARGET),bcm2709)
+  TARGET_DEVICES += rpi-2
+endif
 
 define Device/rpi-3
-  SUBTARGETS := bcm2710
-  DEVICE_TITLE := Raspberry Pi 3 B
-  DEVICE_DTS := bcm2710-rpi-3-b
-  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+  DEVICE_TITLE := Raspberry Pi 3 B/CM
+  DEVICE_DTS := bcm2710-rpi-3-b bcm2710-rpi-cm3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
 endef
-TARGET_DEVICES += rpi-3
+ifeq ($(SUBTARGET),bcm2710)
+  TARGET_DEVICES += rpi-3
+endif
 
 $(eval $(call BuildImage))