kernel: remove duplicate br-netfilter file and Kconfig symbol from kmod-ebtables
[openwrt/staging/rmilecki.git] / package / kernel / linux / modules / netfilter.mk
index 6876f245dfebd2a681e6a3a27fd67604c7491b3e..ccbd20a64349bcd0ba129f7a71bee4d67f54bfd5 100644 (file)
@@ -661,11 +661,8 @@ define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
   DEPENDS:=+kmod-ipt-core +kmod-bridge +kmod-br-netfilter
-  FILES:= \
-       $(LINUX_DIR)/net/bridge/br_netfilter.ko \
-       $(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
-  KCONFIG:=CONFIG_BRIDGE_NETFILTER \
-       $(KCONFIG_EBTABLES)
+  FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
+  KCONFIG:=$(KCONFIG_EBTABLES)
   AUTOLOAD:=$(call AutoProbe,$(notdir $(EBTABLES-m)))
 endef