build: make GCC version 6+ minimal host build requirement
[openwrt/staging/rmilecki.git] / include / prereq-build.mk
index f88e853b52038d24e2db82fc13adc4b6c5f74214..8a6c4bb4684013d343e1f03f1b1ea995a68b9216 100644 (file)
@@ -25,21 +25,21 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 ifndef IB
 $(eval $(call SetupHostCommand,gcc, \
-       Please install the GNU C Compiler (gcc) 4.8 or later, \
-       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
-       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       Please install the GNU C Compiler (gcc) 6 or later, \
+       $(CC) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       gcc -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       \nPlease reinstall the GNU C Compiler (4.8 or later) - \
+       \nPlease reinstall the GNU C Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-       Please install the GNU C++ Compiler (g++) 4.8 or later, \
-       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
-       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       Please install the GNU C++ Compiler (g++) 6 or later, \
+       $(CXX) -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
+       g++ -dumpversion | grep -E '^([6-9]\.?|10\.?)', \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \