target: Make TARGET_SERIAL independent of GRUB configuration
[openwrt/staging/pepe2k.git] / target / linux / armsr / image / Makefile
index e5be3fbe38f426d16aa94a38f552586c6e835263..ec566c5818f8496900c61bebde00f597c24d3fbf 100644 (file)
@@ -15,7 +15,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
   GRUB_TERMINALS += console
 endif
 
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
 
 GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
 GRUB_TERMINALS += serial