mac80211: ath6kl: add missing usb-core dependency to kmod-ath6kl-usb
[openwrt/staging/pepe2k.git] / package / kernel / mac80211 / Makefile
index c0a430051d5234fcf97a11a0193f987eb427e867..7e9b5ad61814aa3a7e7c38236c8741b21ac5352f 100644 (file)
@@ -244,7 +244,7 @@ define KernelPackage/ath6kl-usb
   $(call KernelPackage/mac80211/Default)
   TITLE:=Atheros 802.11n USB wireless cards support
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath6kl
-  DEPENDS+= @USB_SUPPORT +kmod-ath6kl
+  DEPENDS+= @USB_SUPPORT +kmod-usb-core +kmod-ath6kl
   FILES:= $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath6kl/ath6kl_usb.ko
   AUTOLOAD:=$(call AutoProbe,ath6kl_usb)
 endef