at91: switch to Kernel 5.15 by default
[openwrt/staging/noltari.git] / target / linux / at91 / Makefile
index 446de340555899dd6fbcf8402b5376e50a78a768..7867290b7ea1d51f4d619ce1c267c6c93abab1e8 100644 (file)
@@ -1,27 +1,21 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2013 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usbgadget ubifs
+SUBTARGETS:=sama7 sama5 sam9x
 
-LINUX_VERSION:=2.6.34.7
-DEVICE_TYPE=
+KERNEL_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-usb-ohci
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))