at91: switch to Kernel 5.15 by default
[openwrt/staging/noltari.git] / target / linux / at91 / Makefile
index 0ef55e6410c2167df2018288a227989322462e1b..7867290b7ea1d51f4d619ce1c267c6c93abab1e8 100644 (file)
@@ -1,25 +1,21 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2013 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-SUBTARGETS:=netus tqma9263
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usbgadget ubifs
+SUBTARGETS:=sama7 sama5 sam9x
 
-LINUX_VERSION:=2.6.35.11
-DEVICE_TYPE=
+KERNEL_PATCHVER:=5.15
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES+= kmod-usb-ohci
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))