armvirt: merge arm64 as subtarget 64
[openwrt/staging/noltari.git] / target / linux / armvirt / Makefile
index 3fedcad0a045f2a7834e4731df269cacf8285bc5..2cf3820630b5895896a2b6f76d0122d094b4b140 100644 (file)
@@ -1,28 +1,20 @@
 #
-# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=armvirt
 BOARDNAME:=QEMU ARM Virtual Machine
 FEATURES:=fpu pci rtc usb
 FEATURES+=cpiogz ext4 ramdisk squashfs targz
-CPU_TYPE:=cortex-a15
-CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+MAINTAINER:=Florian Fainelli <f.fainelli@gmail.com>, \
+       Yousong Zhou <yszhou4tech@gmail.com>
 
-KERNEL_PATCHVER:=4.4
-
-define Target/Description
-  Build images for QEMU ARM Virtual Machine
-endef
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:=zImage
-
 $(eval $(call BuildTarget))