kernel: kmod-serial-8250: fix linux 5.3 dependencies
[openwrt/staging/noltari.git] / package / kernel / linux / modules / other.mk
index 147ad99cd19c46889acdf2788bcee7af1afa99aa..f1a70bf069145d1c8ebd85a99eb1b23d3ff51ff8 100644 (file)
@@ -732,7 +732,8 @@ define KernelPackage/serial-8250
   FILES:= \
        $(LINUX_DIR)/drivers/tty/serial/8250/8250.ko \
        $(LINUX_DIR)/drivers/tty/serial/8250/8250_base.ko \
-       $(if $(CONFIG_PCI),$(LINUX_DIR)/drivers/tty/serial/8250/8250_pci.ko)
+       $(if $(CONFIG_PCI),$(LINUX_DIR)/drivers/tty/serial/8250/8250_pci.ko) \
+       $(if $(CONFIG_GPIOLIB),$(LINUX_DIR)/drivers/tty/serial/serial_mctrl_gpio.ko@ge5.3)
   AUTOLOAD:=$(call AutoProbe,8250 8250_base 8250_pci)
 endef