qualcommax: ipq60xx: add support for netgear wax214
[openwrt/staging/nbd.git] / target / linux / qualcommax / image / ipq60xx.mk
index 00dead93ad1f2984dfcd154d5fb04b5ab2fd9273..a7851e3dc586711550aa44b277efb32032573db1 100644 (file)
@@ -10,3 +10,16 @@ define Device/8devices_mango-dvk
        DEVICE_PACKAGES := ipq-wifi-8devices_mango
 endef
 TARGET_DEVICES += 8devices_mango-dvk
+
+define Device/netgear_wax214
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_VENDOR := Netgear
+       DEVICE_MODEL := WAX214
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_DTS_CONFIG := config@cp03-c1
+       SOC := ipq6010
+       DEVICE_PACKAGES := ipq-wifi-netgear_wax214
+endef
+TARGET_DEVICES += netgear_wax214