treewide: cleanup kernel symbol references
[openwrt/staging/nbd.git] / package / kernel / linux / modules / input.mk
index 6cc72207f3ebdd6af0c3299ed785692ce994b593..92587b1874cf05902f6f4fc1d31996840c67ecc8 100644 (file)
@@ -92,7 +92,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
 define KernelPackage/input-gpio-keys-polled
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Polled GPIO key support
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-core +LINUX_5_10:kmod-input-polldev
+  DEPENDS:=@GPIO_SUPPORT +kmod-input-core
   KCONFIG:= \
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
@@ -142,21 +142,6 @@ endef
 $(eval $(call KernelPackage,input-joydev))
 
 
-define KernelPackage/input-polldev
-  SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=Polled Input device support
-  DEPENDS:=+kmod-input-core @LINUX_5_10
-  KCONFIG:=CONFIG_INPUT_POLLDEV
-  FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-endef
-
-define KernelPackage/input-polldev/description
- Kernel module for support of polled input devices
-endef
-
-$(eval $(call KernelPackage,input-polldev))
-
-
 define KernelPackage/input-matrixkmap
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Input matrix devices support