scripts/download.pl: make the download tool configurable
[openwrt/staging/nbd.git] / include / download.mk
index 9ff71540f756ff5e6980a86e944917d7e05e601b..34d31653b1a4d8600ac00ae1ad33546502149e1c 100644 (file)
@@ -20,6 +20,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
 # Export options for download.pl
 export DOWNLOAD_CHECK_CERTIFICATE:=$(CONFIG_DOWNLOAD_CHECK_CERTIFICATE)
+export DOWNLOAD_TOOL_CUSTOM:=$(CONFIG_DOWNLOAD_TOOL_CUSTOM)
 
 define dl_method_git
 $(if $(filter https://github.com/% git://github.com/%,$(1)),github_archive,git)