mpc85xx: Fix output location of padded dtb
[openwrt/staging/mkresin.git] / target / linux / mpc85xx / image / Makefile
index e1d1bc694828e5611e333b8b2a453b4343d9930b..d502650a321c6f92d04bffedd8b07aea87d387ce 100644 (file)
@@ -5,8 +5,8 @@ include $(INCLUDE_DIR)/image.mk
 
 DEVICE_VARS += DTB_SIZE
 
-define Build/dtb
-       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb,,--space $(DTB_SIZE))
+define Build/pad-dtb
+       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(dir $@)/image-$(DEVICE_DTS).dtb,,--space $(DTB_SIZE))
 endef
 
 define Device/Default