mt76: update to the latest version
[openwrt/staging/mkresin.git] / package / kernel / mt76 / Makefile
index 7885825aaa5ecd42a22b086b7c4d32e88b570d20..3428ea1f782610f769dc0c7cd353e9683a215fc9 100644 (file)
@@ -1,16 +1,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mt76
-PKG_RELEASE=2
+PKG_RELEASE=1
 
 PKG_LICENSE:=GPLv2
 PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2017-02-03
-PKG_SOURCE_VERSION:=a5eaeb27d6a80c012ffc8b5bb5549983e446b4ef
-PKG_MIRROR_HASH:=c526586aba890c5645320145219bd5932e39cfc2ea540d7674c9a58ab9a4a36a
+PKG_SOURCE_DATE:=2017-10-12
+PKG_SOURCE_VERSION:=37654d704772512065cd28b007342758c2a0f14a
+PKG_MIRROR_HASH:=487ca40ed4e1ffe015dabc76c0a84782602d84f5b08c9c86cc6c892cb499623b
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1
@@ -82,6 +82,10 @@ define Build/Compile
                modules
 endef
 
+define Package/kmod-mt76/install
+       true
+endef
+
 define KernelPackage/mt76x2/install
        $(INSTALL_DIR) $(1)/lib/firmware
        cp \
@@ -92,7 +96,7 @@ endef
 
 define KernelPackage/mt7603/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       cp $(if $(CONFIG_TARGET_ramips_mt7628)$(CONFIG_TARGET_ramips_mt7688), \
+       cp $(if $(CONFIG_TARGET_ramips_mt76x8), \
                $(PKG_BUILD_DIR)/firmware/mt7628_e1.bin \
                $(PKG_BUILD_DIR)/firmware/mt7628_e2.bin \
                ,\