kernel: usb-net-asix: fix 5.15 dependency
[openwrt/staging/mkresin.git] / package / kernel / linux / modules / usb.mk
index fd7ce412d089c1c2b19f81543ea382cade7f166f..c9c1dfd75f923f96a1695ba1cbc1348cdf9e0113 100644 (file)
@@ -1138,7 +1138,7 @@ $(eval $(call KernelPackage,usb-net-aqc111))
 
 define KernelPackage/usb-net-asix
   TITLE:=Kernel module for USB-to-Ethernet Asix convertors
-  DEPENDS:=+kmod-libphy
+  DEPENDS:=+kmod-libphy +LINUX_5_15:kmod-net-selftests +LINUX_5_15:kmod-mdio-devres
   KCONFIG:=CONFIG_USB_NET_AX8817X
   FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/asix.ko
   AUTOLOAD:=$(call AutoProbe,asix)