package/uboot-omap: install image to STAGING_DIR_IMAGE
[openwrt/staging/lynxis/omap.git] / package / boot / uboot-omap / Makefile
index 0369b07d3d828f1d1e2849c74e3af0c788412de8..17a4af42f2d9246fd4ea3ccf7f97dffa511aaa14 100644 (file)
@@ -6,28 +6,29 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2015.10
+PKG_VERSION:=2017.01
 PKG_RELEASE:=1
 
-PKG_HASH:=bdc68d5f9455ad933b059c735d983f2c8b6b552dafb062e5ff1444f623021955
+PKG_HASH:=6c425175f93a4bcf2ec9faf5658ef279633dbd7856a293d95bd1ff516528ecf2
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
 
 define U-Boot/Default
   BUILD_TARGET:=omap
-  BUILD_DEVICES:=Default
   UBOOT_IMAGE:=u-boot.img MLO
-  HIDDEN:=1
 endef
 
 define U-Boot/omap4_panda
   NAME:=Pandaboard
+  BUILD_DEVICES:=omap4-panda
 endef
 
 define U-Boot/am335x_evm
   NAME:=AM335x EVM
+  BUILD_DEVICES:=am335x-evm
 endef
 
 define U-Boot/omap3_overo
@@ -36,9 +37,14 @@ endef
 
 define U-Boot/omap3_beagle
   NAME:=BeagleBoard
+  BUILD_DEVICES:=omap3-beagle
 endef
 
 UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
-UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
+       $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
+endef
 
 $(eval $(call BuildPackage/U-Boot))