add CPE ids to package and tools
[openwrt/staging/lynxis.git] / tools / dosfstools / Makefile
index 73d8e2a36a101bd6d8b2ca3fc78675d7aacb9e61..9a6b5847c679d2459b9b240c1afb46ecd62afc20 100644 (file)
@@ -1,5 +1,6 @@
-# 
-# Copyright (C) 2012 OpenWrt.org
+#
+# Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE-Project.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,24 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
-PKG_VERSION:=3.0.7
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://dosfstools.sourcearchive.com/downloads/3.0.7/
-PKG_MD5SUM:=5d4d97c79e8dae60bb08c2fba36c94d6
-PKG_CAT:=zcat
+PKG_CPE=cpe:/a:dosfstools_project:dosfstools
+PKG_VERSION:=4.1
 
-include $(INCLUDE_DIR)/host-build.mk
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
+               http://fossies.org/linux/misc
+PKG_HASH:=e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_LDFLAGS) -static"
-endef
+HOST_FIXUP:=autoreconf
 
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkdosfs $(STAGING_DIR_HOST)/bin/
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/mkdosfs
-endef
+ifeq ($(HOST_OS),Darwin)
+HOST_CFLAGS += -UHAVE_ENDIAN_H
+endif
 
 $(eval $(call HostBuild))