sunxi: add Orange Pi R1 support
[openwrt/staging/lynxis.git] / target / linux / sunxi / image / cortex-a7.mk
index ecf376fbe4caabd6614be869cc9684ea925fdf73..29c30ef494516e426536e3300ae219f2f0ff19b6 100644 (file)
@@ -108,6 +108,16 @@ endef
 TARGET_DEVICES += sun6i-a31-m9
 
 
+define Device/sun8i-h2-plus-orangepi-r1
+  DEVICE_TITLE:=Xunlong Orange Pi R1
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+  SUPPORTED_DEVICES:=xunlong,orangepi-r1
+  SUNXI_DTS:=sun8i-h2-plus-orangepi-r1
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+
+
 define Device/sun8i-h3-orangepi-plus
   DEVICE_TITLE:=Xunlong Orange Pi Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi