ath79: add support for D-Link DIR-842 C1
[openwrt/staging/lynxis.git] / target / linux / ath79 / image / generic.mk
index 42e4271e0cdfac17244f9b45dd1b93d214696a2c..80095827788b3faa88b161376f8ad2f62f85918b 100644 (file)
@@ -365,11 +365,10 @@ define Device/dlink_dir-859-a1
 endef
 TARGET_DEVICES += dlink_dir-859-a1
 
-define Device/dlink_dir-842-c2
+define Device/dlink_dir-842-c
   ATH_SOC := qca9563
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-842
-  DEVICE_VARIANT := C2
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := $$(KERNEL) | seama
   IMAGES += factory.bin
@@ -384,7 +383,19 @@ define Device/dlink_dir-842-c2
   IMAGE/factory.bin := \
        $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size $$$$(IMAGE_SIZE)
   IMAGE_SIZE := 15680k
-  DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+
+define Device/dlink_dir-842-c1
+       $(Device/dlink_dir-842-c)
+       DEVICE_VARIANT := C1
+       DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+endef
+TARGET_DEVICES += dlink_dir-842-c1
+
+define Device/dlink_dir-842-c2
+       $(Device/dlink_dir-842-c)
+       DEVICE_VARIANT := C2
+       DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9888-ct
 endef
 TARGET_DEVICES += dlink_dir-842-c2