at91: Add UBI parameters for sama5d4.
[openwrt/staging/lynxis.git] / target / linux / at91 / image / Makefile
index 99c7e21669e1150006a934b9dd90f6017e561646..93337097c08f31f94e0a26af4cabff331cfa6b58 100644 (file)
@@ -16,7 +16,12 @@ endif
 
 ifeq ($(SUBTARGET),sama5)
 include ./sama5.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+ifeq ($(TARGET_DEVICES),at91-sama5d4_xplained)
+  UBIFS_OPTS := -e 0x3e000 -c 2082 -m 0x1000 -x lzo
+  UBINIZE_OPTS := -m 0x1000 -p 0x40000
+else
+  UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+endif
 endif
 
 define Device/Default