add CPE ids to package and tools
[openwrt/staging/lynxis.git] / package / libs / libunwind / Makefile
index 6cec8a73452d8c364a443bb0175e403fadb46549..cd13fed1b12f7593ceb1d06679df375536a07c16 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +9,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libunwind
-PKG_VERSION:=1.1
+PKG_VERSION:=1.2.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_MD5SUM:=fb4ea2f6fbbe45bf032cd36e586883ce
+PKG_HASH:=3f3ecb90e28cbe53fba7a4a27ccce7aad188d3210bb1964a923a731a27a75acb
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 PKG_LICENSE:=X11
 PKG_LICENSE_FILES:=LICENSE
+PKG_CPE=cpe:/a:libunwind_project:libunwind
 
 PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
 
@@ -36,7 +38,10 @@ define Package/libunwind/description
   Libunwind defines a portable and efficient C programming interface (API) to determine the call-chain of a program.
 endef
 
-CONFIGURE_ARGS += --enable-minidebuginfo=no
+CONFIGURE_ARGS += \
+       --disable-documentation \
+       --enable-minidebuginfo=no \
+
 
 define Package/libunwind/install
        $(INSTALL_DIR) $(1)/usr/lib