Revert "amd64-microcode: create early load microcode image"
[openwrt/staging/lynxis.git] / package / firmware / amd64-microcode / Makefile
index adf3352af2e5d13b6e6d9c9908964b629818e768..4fd3d0461043328aee5f0852fdfc94f99cdf6da6 100644 (file)
@@ -35,17 +35,11 @@ define Build/Prepare
 endef
 
 define Build/Compile
-       mkdir -p $(PKG_BUILD_DIR)/kernel/x86/microcode/
-       cat $(PKG_BUILD_DIR)/microcode_amd*.bin \
-               > $(PKG_BUILD_DIR)/kernel/x86/microcode/AuthenticAMD.bin
-       (cd $(PKG_BUILD_DIR); \
-       echo "kernel/x86/microcode/AuthenticAMD.bin" \
-               | cpio -o -H newc --reproducible > amd-ucode.cpio)
 endef
 
 define Package/amd64-microcode/install
-       $(INSTALL_DIR) $(1)/boot
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/amd-ucode.cpio $(1)/boot/amd-ucode.img
+       $(INSTALL_DIR) $(1)/lib/firmware/amd-ucode
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/*.bin $(1)/lib/firmware/amd-ucode
 endef
 
 $(eval $(call BuildPackage,amd64-microcode))