add CPE ids to package and tools
[openwrt/staging/lynxis.git] / package / devel / gdb / Makefile
index dc8df7c5a26d74c442e2e5920b9c1d6403e8c94d..12bdec3ead898b185e086c07c2813bcebd3d342c 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.11.1
+PKG_VERSION:=8.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=e9216da4e3755e9f414c1aa0026b626251dfc57ffe572a266e98da4f6988fc70
+PKG_HASH:=3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_LICENSE:=GPL-3.0+
+PKG_CPE=cpe:/a:gnu:gdb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -55,17 +56,15 @@ CONFIGURE_ARGS+= \
        --with-system-readline \
        --without-expat \
        --without-lzma \
+       --disable-sim \
        --disable-werror
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all
-endef
+TARGET_LDFLAGS+= \
+       -static-libstdc++ \
+       -Wl,--gc-sections
 
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) \