uboot-at91: move BUILD_SUBTARGET from U-Boot/Default to devices
[openwrt/staging/lynxis.git] / package / boot / uboot-at91 / Makefile
index 6a806ff635f1907f3ae1c8a19f2274dc045784aa..68e4ba498bc3eaea81a98857072f7108b3a0f578 100644 (file)
@@ -17,16 +17,17 @@ include $(INCLUDE_DIR)/package.mk
 
 define U-Boot/Default
   BUILD_TARGET:=at91
-  BUILD_SUBTARGET:=legacy
   UBOOT_IMAGE:=u-boot.bin boot.bin
 endef
 
 define U-Boot/at91sam9m10g45ek_nandflash
   NAME:=AT91SAM9M10G45-EK board (NandFlash)
+  BUILD_SUBTARGET:=legacy
 endef
 
 define U-Boot/at91sam9x5ek_nandflash
   NAME:=AT91SAM9X5-EK board (NandFlash)
+  BUILD_SUBTARGET:=legacy
 endef
 
 UBOOT_TARGETS := \