uboot-at91: Add support for SAMA5D3 Xplained board
[openwrt/staging/lynxis.git] / package / boot / uboot-at91 / Makefile
index 68e4ba498bc3eaea81a98857072f7108b3a0f578..2c95377b0fb0f95cc7cabd0ba2b7ec429b303136 100644 (file)
@@ -30,9 +30,23 @@ define U-Boot/at91sam9x5ek_nandflash
   BUILD_SUBTARGET:=legacy
 endef
 
+define uboot/sama5d3_xplained_nandflash
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (NandFlash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
+define uboot/sama5d3_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D3 Xplained board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d3_xplained
+endef
+
 UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
-       at91sam9x5ek_nandflash
+       at91sam9x5ek_nandflash \
+    sama5d3_xplained_nandflash \
+    sama5d3_xplained_mmc
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \