build: add image command for installing zImage file.
[openwrt/staging/lynxis.git] / include / image-commands.mk
index 2aac8fb15d2e125de10ef5179952173b01b63b00..acf25d64da83d4f1d3577474b717978a7c95cc09 100644 (file)
@@ -114,6 +114,11 @@ define Build/install-dtb
        )
 endef
 
+define Build/install-zImage
+    $(CP) $(KDIR)/zImage \
+      $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE_SANITIZED)-zImage
+endef
+
 define Build/fit
        $(TOPDIR)/scripts/mkits.sh \
                -D $(DEVICE_NAME) -o $@.its -k $@ \