mvebu: add ClearFog Base support
[openwrt/staging/luka.git] / target / linux / mvebu / image / Makefile
index dcbf4a67b37983181773f13f6cde0f06a8a0cc7f..f112bb9a1e2327e717afe46dffc01bc364b151ab 100644 (file)
@@ -28,6 +28,11 @@ define Build/boot-scr-cfpro
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
 endef
 
+define Build/boot-scr-cfbase
+       rm -f $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
+endef
+
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot 16384
@@ -182,6 +187,21 @@ define Device/armada-388-clearfog-pro
 endef
 TARGET_DEVICES += armada-388-clearfog-pro
 
+define Device/armada-388-clearfog-base
+  KERNEL_INSTALL := 1
+  KERNEL := dtb | kernel-bin
+  DEVICE_TITLE := SolidRun ClearFog Base
+  DEVICE_PACKAGES := \
+         kmod-nls-cp437 kmod-nls-iso8859-1 \
+         mkf2fs e2fsprogs kmod-fs-vfat kmod-fuse kmod-fs-f2fs \
+         kmod-ata-core kmod-ata-ahci kmod-ata-marvell-sata kmod-scsi-core kmod-scsi-generic \
+         kmod-button-hotplug kmod-gpio-button-hotplug
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
+  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+endef
+TARGET_DEVICES += armada-388-clearfog-base
+
 define Device/globalscale-mirabox
   $(Device/NAND-512K)
   DEVICE_DTS := armada-370-mirabox