bcm63xx: lzma-loader: rely on CHIP_ID for UART address
[openwrt/staging/luka.git] / target / linux / bcm63xx / image / lzma-loader / src / Makefile
index 167bf6455adeb11e844725249457f1233afc6e76..9115f75af375c2f806e1c5251e5ae4245bcfcb45 100644 (file)
@@ -2,6 +2,8 @@
 # Makefile for the LZMA compressed kernel loader for
 # Atheros AR7XXX/AR9XXX based boards
 #
+# Copyright (C) 2020 Álvaro Fernández Rojas <noltari@gmail.com>
+# Copyright (C) 2014 Jonas Gorski <jogo@openwrt.org>
 # Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
 #
 # Some parts of this file was based on the OpenWrt specific lzma-loader
@@ -34,6 +36,7 @@ CFLAGS                = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -mabi=32 -march=mips32 \
                  -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
 CFLAGS         += -D_LZMA_PROB32
+CFLAGS         += -DUART_BASE=$(UART_BASE)
 
 ASFLAGS                = $(CFLAGS) -D__ASSEMBLY__
 
@@ -82,6 +85,3 @@ mrproper: clean
 
 clean:
        rm -f loader *.elf *.bin *.o
-
-
-