bcm63xx: WIP: add Huawei HG253s v2 support
[openwrt/staging/luka.git] / target / linux / bcm63xx / image / bcm63xx_nand.mk
index c70fdf8b2f5c31a5b5e5ed80478d8d62299e5a5a..5483c73077e83306c261659dcbf61e9f66f5d2f8 100644 (file)
@@ -71,6 +71,28 @@ define Device/comtrend_vg-8050
 endef
 TARGET_DEVICES += comtrend_vg-8050
 
+### Huawei ###
+define Device/huawei_hg253s-v2
+  $(Device/bcm63xx-nand)
+  IMAGES := flash.bin sysupgrade.bin
+  IMAGE/flash.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | cfe-jffs2-cferam | append-ubi
+  DEVICE_VENDOR := Huawei
+  DEVICE_MODEL := HG253s
+  DEVICE_VARIANT := v2
+  CHIP_ID := 6362
+  CFE_PART_FLAGS := 1
+  CFE_PART_ID := 0x0001EFEE
+  CFE_RAM_FILE := huawei,hg253s-v2/cferam.000
+  CFE_RAM_JFFS2_NAME := cferam.000
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 512
+  VID_HDR_OFFSET := 2048
+  DEVICE_PACKAGES += $(USB2_PACKAGES)
+  CFE_WFI_FLASH_TYPE := 3
+endef
+TARGET_DEVICES += huawei_hg253s-v2
+
 ### Netgear ###
 define Device/netgear_dgnd3700-v2
   $(Device/bcm63xx-nand)