lua5.3: fix build with MacOS's make
[openwrt/staging/luka.git] / package / utils / lua5.3 / patches-host / 001-include-version-number.patch
index 08990f52ca2cd221ad4144653cd4234556ea43ca..78f00549607f98421ca89d9cba9595ef27285949 100644 (file)
@@ -34,6 +34,15 @@ diff --git a/Makefile b/Makefile
  
  # Lua version and release.
  V= 5.3
+@@ -52,7 +52,7 @@ R= $V.4
+ all:  $(PLAT)
+ $(PLATS) clean:
+-      cd src && $(MAKE) $@
++      cd src && $(MAKE) $@ V=$V
+ test: dummy
+       src/lua -v
 diff --git a/doc/lua.1 b/doc/lua5.3.1
 rename from doc/lua.1
 rename to doc/lua5.3.1