busybox: Move libresolv detection to LEDE Makefile
[openwrt/staging/luka.git] / package / utils / busybox / Makefile
index be4b967a47d4818961ab88172d978e942f9faec7..c87243b93c1ff0aaaead42b5dc9c16f645fdb7ae 100644 (file)
@@ -85,6 +85,12 @@ ifdef CONFIG_BUSYBOX_CONFIG_PAM
   LDLIBS += pam pam_misc pthread
 endif
 
+ifdef CONFIG_BUSYBOX_DEFAULT_NSLOOKUP_LEDE
+  ifeq ($(CONFIG_USE_GLIBC),y)
+       LDLIBS += resolv
+  endif
+endif
+
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \