x86: added support to generate VHDX images
[openwrt/staging/jow.git] / target / linux / x86 / Makefile
index 422e828d4da17192f801f6908b2b6d3e2b475932..e42d87fbc99a86975a3f644eaa927a5dd539c976 100644 (file)
@@ -1,23 +1,28 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan
+FEATURES:=squashfs ext4 vdi vmdk vhdx pcmcia targz fpu boot-part rootfs-part
+SUBTARGETS:=generic legacy geode 64
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=5.10
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs kmod-button-hotplug
+
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))