sunxi: build image for the NanoPi NEO
[openwrt/staging/jow.git] / target / linux / sunxi / image / cortex-a7.mk
index ecf376fbe4caabd6614be869cc9684ea925fdf73..d0b7aa04b606f5ea3526d1b2bf9e654bffc56e6f 100644 (file)
@@ -108,6 +108,25 @@ endef
 TARGET_DEVICES += sun6i-a31-m9
 
 
+define Device/sun8i-h2-plus-orangepi-r1
+  DEVICE_TITLE:=Xunlong Orange Pi R1
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
+  SUPPORTED_DEVICES:=xunlong,orangepi-r1
+  SUNXI_DTS:=sun8i-h2-plus-orangepi-r1
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
+
+
+define Device/sun8i-h3-nanopi-neo
+  DEVICE_TITLE:=FriendlyARM NanoPi NEO
+  SUPPORTED_DEVICES:=friendlyarm,nanopi-neo
+  SUNXI_DTS:=sun8i-h3-nanopi-neo
+endef
+
+TARGET_DEVICES += sun8i-h3-nanopi-neo
+
+
 define Device/sun8i-h3-orangepi-plus
   DEVICE_TITLE:=Xunlong Orange Pi Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi