omap: rename image for sysupgrade compatibility
[openwrt/staging/jow.git] / target / linux / omap / image / Makefile
index 2f1e5b5ac07d07f2f4039d5a0f3e8ae7f080b7e1..c7271aba8f40dcb27db29308b4c4ad29d34967c2 100644 (file)
@@ -38,34 +38,34 @@ define Device/Default
   KERNEL := kernel-bin
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
-  SUPPORTED_DEVICES = $$(DEVICE_DTS)
+  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
 #uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
 
-define Device/am335x-evm
+define Device/ti_am335x-evm
   DEVICE_TITLE := TI AM335x EVM
   DEVICE_DTS := am335x-evm
 endef
 
-TARGET_DEVICES += am335x-evm
+TARGET_DEVICES += ti_am335x-evm
 
-define Device/am335x-boneblack
+define Device/ti_am335x-bone-black
   DEVICE_TITLE := TI AM335x BeagleBone Black
   DEVICE_DTS := am335x-boneblack
 endef
 
-TARGET_DEVICES += am335x-boneblack
+TARGET_DEVICES += ti_am335x-bone-black
 
-define Device/omap4-panda
+define Device/ti_omap4-panda
   DEVICE_TITLE := OMAP4 TI pandaboard
   DEVICE_DTS := omap4-panda
   DEVICE_PACKAGES := kmod-usb-net-smsc95xx
 endef
 
-TARGET_DEVICES += omap4-panda
+TARGET_DEVICES += ti_omap4-panda
 
-define Device/omap3-beagle
+define Device/ti_omap3-beagle
   DEVICE_TITLE := OMAP3 TI beagleboard
   DEVICE_DTS := omap3-beagle
   # beagleboard doesn't have a network interface, support most common usb net
@@ -75,6 +75,6 @@ define Device/omap3-beagle
        kmod-usb-net-smsc95xx kmod-usb-net-dm9601-ether
 endef
 
-TARGET_DEVICES += omap3-beagle
+TARGET_DEVICES += ti_omap3-beagle
 
 $(eval $(call BuildImage))