at91: fix legacy build
[openwrt/staging/jow.git] / target / linux / at91 / image / Makefile
index 99c7e21669e1150006a934b9dd90f6017e561646..12607073e4a75659180e156133c30bec558dd272 100644 (file)
@@ -11,25 +11,20 @@ KERNEL_LOADADDR := 0x20008000
 
 ifeq ($(SUBTARGET),legacy)
 include ./legacy.mk
-UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
 endif
-
 ifeq ($(SUBTARGET),sama5)
 include ./sama5.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
 endif
 
 define Device/Default
+  $(Device/default-nand)
   PROFILES := Default
   FILESYSTEMS := squashfs ubifs
   DEVICE_DTS := $(1)
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  SUBPAGESIZE := 512
-  DTB_SIZE :=
+  DTB_SIZE := 128k
 endef
 
 define Device/dtb
@@ -56,6 +51,12 @@ define Device/evaluation-dtb
   IMAGE/dtb := install-dtb
 endef
 
+define Device/evaluation-fit
+  $(Device/evaluation)
+  KERNEL_SUFFIX := -fit-uImage.itb
+  KERNEL := kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+endef
+
 define Device/production
   UBINIZE_OPTS := -E 5
   IMAGES := factory.bin
@@ -65,7 +66,6 @@ endef
 define Device/production-dtb
   $(Device/production)
   $(Device/dtb)
-  DTB_SIZE := 128k
   IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
          | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef