at91: Add ext4 filesystem
[openwrt/staging/jow.git] / target / linux / at91 / Makefile
index 7a412c2e41d692916b4ef33f45a8dbf085c7fa25..c4de685d104a26b7b9c5c89ccdffd744e8563d27 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs jffs2 targz ext2 usb
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+SUBTARGETS:=sama5 legacy
 
-LINUX_VERSION:=3.8.12
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-usb-ohci
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))