rules: fix broken commitcount on alpine system
[openwrt/staging/jow.git] / rules.mk
index 2de43d490d6c041f11f9c41d78c34a71833d3c30..e17852e02177e3b6b01cd9aff655a16381181d73 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -409,7 +409,7 @@ $(shell \
   if git log -1 >/dev/null 2>/dev/null; then \
     if [ -n "$(1)" ]; then \
       last_bump="$$(git log --pretty=format:'%h %s' . | \
-        grep --max-count=1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \
+        grep -1 -e ': [uU]pdate to ' -e ': [bB]ump to ' | \
         cut -f 1 -d ' ')"; \
     fi; \
     if [ -n "$$last_bump" ]; then \