build: clean up and optimize ipkg control generator code
[openwrt/staging/jow.git] / rules.mk
index f44e8edef405b3a1638f9e342039a7888b85369b..8844a47a1f8aca6b3864bb00283839e40db4cfe5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -21,6 +21,7 @@ qstrip=$(strip $(subst ",,$(1)))
 
 empty:=
 space:= $(empty) $(empty)
+comma:=,
 merge=$(subst $(space),,$(1))
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))