iproute2: bump to 4.13
[openwrt/staging/jow.git] / package / network / utils / iproute2 / patches / 300-ip_tiny.patch
index e1b1da4d20f986a74d8a729bced0dae0aba7b6ba..d48ea8581c78b5df111f1b2bac9805e5617b4d9b 100644 (file)
@@ -1,7 +1,7 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -19,6 +19,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
-       CFLAGS += -DHAVE_SETNS
+@@ -28,6 +28,13 @@ ifeq ($(HAVE_MNL),y)
+       LDLIBS += $(shell $(PKG_CONFIG) libmnl --libs)
  endif
  
 +STATIC_SYM_FILTER:=
@@ -14,7 +14,7 @@
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
-@@ -48,7 +55,7 @@ else
+@@ -57,7 +64,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
        { "netconf",    do_ipnetconf },
 +#endif
        { "vrf",        do_ipvrf},
+       { "sr",         do_seg6 },
        { "help",       do_help },
-       { 0 }
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -777,6 +777,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -787,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
                return inet_ntop(af, addr, buf, buflen);
        case AF_MPLS:
                return mpls_ntop(af, addr, buf, buflen);
@@ -80,7 +80,7 @@
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -786,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -796,6 +797,7 @@ const char *rt_addr_n2a_r(int af, int le
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
@@ -90,8 +90,8 @@
        default:
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
-       CFLAGS += -DHAVE_SETNS
+@@ -12,6 +12,10 @@ ifeq ($(HAVE_MNL),y)
+       CFLAGS += -DHAVE_LIBMNL $(shell $(PKG_CONFIG) libmnl --cflags)
  endif
  
 +ifeq ($(IP_CONFIG_TINY),y)