Revert "prereq-build: add Python 3.12 support"
[openwrt/staging/jow.git] / include / prereq-build.mk
index 2378f5ad90c961472f8751f2d116f9978d976b7d..49340ce3e441ccbaa1833d6eb38d8abd450f627e 100644 (file)
@@ -182,7 +182,6 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
-       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -191,7 +190,6 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
        python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
-       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \