ipq807x: renumber upstreamed patches
[openwrt/staging/jow.git] / Makefile
index cbf9fa2cd1385e93d8e77cf961a69cfe9445b5be..c325034bb9da4f8b1d1e90af7183df75a1d1c2d0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,9 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
 world:
 
 DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
-export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
+export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)
   _SINGLE=export MAKEFLAGS=$(space);