build: add xargs as prerequisite
[openwrt/staging/jogo.git] / include / prereq-build.mk
index a711ae33f7edd9d5ec494fc4d0e0e6a363a7ed85..6fec4c1a4a6c5866ce01c3228a3fa5122e4ddb2e 100644 (file)
@@ -93,6 +93,11 @@ $(eval $(call SetupHostCommand,find,Please install GNU 'find', \
 $(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
        bash --version 2>&1 | grep GNU))
 
+$(eval $(call SetupHostCommand,xargs, \
+       Please install 'xargs' that supports '-r/--no-run-if-empty', \
+       gxargs -r --version, \
+       xargs -r --version))
+
 $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
        gpatch --version 2>&1 | grep 'Free Software Foundation', \
        patch --version 2>&1 | grep 'Free Software Foundation'))