tools/e2fsprogs: fix build under macos
[openwrt/staging/hauke.git] / tools / e2fsprogs / Makefile
index 039959e4248cc7c0d53e11afc4dc9487bd2f6074..d7c994c3385d853c22f1e505ceb4d8d419ddd0fc 100644 (file)
@@ -21,7 +21,7 @@ HOST_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/host-build.mk
 
 ifneq ($(shell $(HOSTCC) --version | grep clang),)
-  HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0
+  HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0 -Dloff_t=off_t
 endif
 HOST_CFLAGS += $(FPIC)