at91: separate MKUBIFS opts to defaults in the sub target
[openwrt/staging/hauke.git] / target / linux / at91 / image / Makefile
index d1ae61484a713428fb3db246052cdc3be30536e8..db480ac754506cbaed6be4cf628a7757b6c800f1 100644 (file)
@@ -11,23 +11,19 @@ KERNEL_LOADADDR := 0x20008000
 
 ifeq ($(SUBTARGET),legacy)
 include ./legacy.mk
-UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
 endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
-UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
 endif
 
 define Device/Default
+  $(Device/default-nand)
   PROFILES := Default
   FILESYSTEMS := squashfs ubifs
   DEVICE_DTS := $(1)
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  SUBPAGESIZE := 512
   DTB_SIZE :=
 endef
 
@@ -42,9 +38,15 @@ define Device/evaluation
   IMAGE/root.ubi := append-ubi
 endef
 
+define Device/evaluation-zImage
+  IMAGES += zImage
+  IMAGE/zImage := install-zImage
+endef
+
 define Device/evaluation-dtb
   $(Device/evaluation)
   $(Device/dtb)
+  $(Device/evaluation-zImage)
   IMAGES += dtb
   IMAGE/dtb := install-dtb
 endef