gre: squash grev4 and grev6 packages into gre (FS#1399)
[openwrt/staging/hauke.git] / package / network / config / gre / Makefile
index b191327f873c43eb958515afcc7f859da55a0cdb..73319e80cffbf655639bf1de36ee580cc28b1938 100644 (file)
@@ -15,40 +15,21 @@ PKG_LICENSE:=GPL-2.0
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gre/Default
-  SECTION:=net
-  CATEGORY:=Network
-  MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
 endef
 
 define Package/gre
-$(call Package/gre/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
   TITLE:=Generic Routing Encapsulation config support
+  DEPENDS:=+kmod-gre +IPV6:kmod-gre6 +resolveip
+  PROVIDES:=grev4 grev6
 endef
 
 define Package/gre/description
  Generic Routing Encapsulation config support (IPv4 and IPv6) in /etc/config/network.
 endef
 
-define Package/grev4
-$(call Package/gre/Default)
-  TITLE:=Generic Routing Encapsulation (IPv4) config support
-  DEPENDS:=@(PACKAGE_gre) +kmod-gre +resolveip
-endef
-
-define Package/grev4/description
- Generic Routing Encapsulation config support (IPv4) in /etc/config/network.
-endef
-
-define Package/grev6
-$(call Package/gre/Default)
-  TITLE:=Generic Routing Encapsulation (IPv6) config support
-  DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-gre6 +resolveip
-endef
-
-define Package/grev6/description
- Generic Routing Encapsulation config support (IPv6) in /etc/config/network.
-endef
-
 define Build/Compile
 endef
 
@@ -60,14 +41,4 @@ define Package/gre/install
        $(INSTALL_BIN) ./files/gre.sh $(1)/lib/netifd/proto/gre.sh
 endef
 
-define Package/grev4/install
-       :
-endef
-
-define Package/grev6/install
-       :
-endef
-
 $(eval $(call BuildPackage,gre))
-$(eval $(call BuildPackage,grev4))
-$(eval $(call BuildPackage,grev6))